Автор Тема: Проблема монтирования SMB шары Windows сервера  (Прочитано 156 раз)

Оффлайн Александр

  • Модератор
  • *****
  • Сообщений: 60
  • Репутация: 1
Т.к. Openoffice не дружит с сетевыми файлами, да и для общего удобства решил примонтировать шару с проектами корпоративного сервера.
Казалось бы все просто - есть куча мануалов, где все расписано. Делаю по писанному:

su root

mkdir /media/sharefolder

nano /root/.smbcredentials
   username=windowsuser
   password=windowspass

chmod 600 /root/.smbcredentials

nano /etc/fstab
   //host/share /media/sharefolder cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

mount /media/sharefolder

И.... ииии...
Цитировать
mount error(112): Host is down
Что за беда?
Ну ладно.
Цитировать
smbclient -U user -W domain -L host
исправно выдает список шар, ОК.
Цитировать
mount -t cifs //host/share /media/sharefolder -o username=user,domain=domain,password=password
И.... ииии...
Цитировать
mount error(112): Host is down
Да что ж такое?!
Спрашиваю у Яндекса и на форуме нахожу ответ.
Цитировать
//192.168.0.10/Nuts /media/Nuts cifs guest,vers=1.0,uid=1000,iocharset=utf8 0 0
Хм. Уж не знаю, что такое vers=1.0, но
Цитировать
mount -t cifs //host/share /media/sharefolder -o username=user,domain=domain,password=password,vers=1.0
И положительный результат.

Цитировать
umount /media/sharefolder

nano /etc/fstab
   //host/share /media/sharefolder cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777,vers=1.0 0 0

mount /media/sharefolder
Урааааа, заработало!!!
Пожалуй, более правильной будет такая строка в /etc/fstab

Цитировать
//host/share /media/sharefolder cifs,_netdev credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777,vers=1.0 0 0

« Последнее редактирование: 01 Июнь 2018, 12:54:39 от Александр »

Оффлайн Александр

  • Модератор
  • *****
  • Сообщений: 60
  • Репутация: 1
_netdev пришлось убрать, т.к. после перезагрузки шара автоматом не монтировалась. Разбираться не стал. По описанию этот параметр должен приводить к монтированию только после поднятия сетевого интерфейса, но по факту в моем дистрибутиве - Calculate Linux (основан на Gentoo) нормально не заработало. Может попозже разберусь.

 

Яндекс.Метрика