Автор Тема: Настройка локали в armbian  (Прочитано 299 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Александр

  • Модератор
  • *****
  • Сообщений: 182
  • Репутация: 1
  • Мощность альтернативной энергоустановки: 800
Настройка локали в armbian
« : 24 Август 2019, 12:38:13 »
Проблемы с кириллицей в Armbian
#dpkg-reconfigure localesрезультата не дает ни сама по себе ни через
#armbian-configПоиск по Интеренет не давал ничего путного, пока не попал на эту статью.
Все оказалось предельно просто
#locale-gen ru_RU.UTF-8
#nano /etc/default/locale
Туда вписать
LANG="ru_RU.UTF-8"
LC_ALL="ru_RU.UTF-8"

Это нормально сработало на Armbian_19.11.3_Cubieboard2_buster_current_5.3.9, но не помогло на Armbian_20.02.0-rc0_Cubieboard2_bionic_current_5.4.12

dpkg-reconfigure locales
Generating locales (this might take a while)...
  ru_RU.UTF-8... done
Generation complete.
*** update-locale: Error: invalid locale settings:  LANG=ru_RU.UTF-8 LANGUAGE= LC_MESSAGES=en_US.UTF-8
Помогло дополнительно
# nano /etc/environmentТуда добавить строку
LANG="ru_RU.utf8"После этого
# apt update
# apt upgrade
« Последнее редактирование: 23 Январь 2020, 16:20:49 от Александр »

 

Яндекс.Метрика